2010年07月10日

CotEditorの次のバージョンからは、Mac OS X 10.4 以降をサポート対象にしたいと考えています

nakamuxu さんが昨年リリースされた CotEditor 1.0.1 は Mac OS X 10.3 以降で動作します。

しかし、CotEditor の次のバージョンからは、Mac OS X 10.3 をサポート対象からはずし、Mac OS X 10.4 以降を対象としたいと考えています。

理由は、10.3 をサポートする開発の負担が大きいと考えるからです。Xcode の少し前のバージョンから 10.3 の SDK がなくなっており、Apple も 10.3 をレガシーとみなしていると思われます。

Mac OS X 10.3 の CotEditor ユーザの方がおられましたら(正直なところどのくらいおられるか把握していません)、申し訳ありませんが、ご理解いただけましたら幸いです。

よろしくお願いいたします。
posted by usami-k at 00:59| Comment(6) | TrackBack(0) | 日記 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
Apple は大体 2世代(今なら 10.5 と 10.6)しかサポートしてない気がしますから、10.4 がサポートされてるだけでもありがたいと思います。
Posted by Hiro at 2010年07月30日 21:04
コメントありがとうございます。

実は、10.4もはずして10.5以降のみ、というパターンも考えました。ただ、10.4で動作しているPowerBookがまだ私自身の手元にあるので、しばらくはサポートしたいと思います。
Posted by usami-k at 2010年07月31日 00:56
nakamuxu さんの開発された CotEditor は、至高のテキストエディタだと思っております。開発を引き継がれた usami-k さんにも深い敬意と謝意を表します。

さて、この場をお借りしてご報告申し上げるのは不適切かもしれませんが、下記の箇所に脱字が見つかりましたので、ご訂正頂ければ幸いです。

CotEditor.app/Contents/Resources/defaultSyntaxStyle_CSS.plist

240行目


<string>letter-spacig</string>


<string>letter-spacing</string>
Posted by ねこ at 2010年10月16日 12:12
返事が遅くなりましたが、ご報告ありがとうございます。次のバージョンで修正します。
Posted by usami-k at 2010年10月21日 12:47
至高のテキストエディタは言い過ぎwまだまだ改良の余地ありだと思うよ。タブ付けてほしいし。
Posted by まるやま at 2011年01月03日 19:23
コメントありがとうございます。改良の余地はあるでしょうね。タブの要望はよく聞くので、検討していきたいと思っています。他にも要望があれば教えてください。どこまで実現できるかはなんとも言えないですが・・・。
Posted by usami-k at 2011年01月05日 01:54
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。